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1 Intorduction

1.1 About Chromasens

The name of our company, Chromasens, is a combination of 'Chroma' which means color, and

'Sens' which stands for sensor technology.
Chromasens designs, develops and produces high-quality and user-friendly products:

m  Color line scan cameras

B 3D stereo line scan cameras

B Multi-spectral line scan cameras
B Camera systems

B Camera illumination systems

B |Image acquisition systems

B Image processing solutions

Today, Chromasens GmbH is experiencing steady growth and is continually penetrating new
sales markets around the globe. The company's technologies are used, for example, in
products and for applications such as book and document scanners, sorting systems and

inspection systems for quality assurance monitoring.

Customers from all over the world of a wide range of industrial sectors have placed their trust

in the experience of Chromasens in the field of industrial image processing.

1.2 Contact Information

Chromasens GmbH
Max-Stromeyer-Str. 116
78467 Konstanz

Germany

Phone: +49 (0) 7531 / 876-0
Fax: +49 (0) 7531 / 876-303

Email: info@chromasens.de

CD40150 Version R04 4
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1.3 Support

Chromasens GmbH
Max-Stromeyer-Str. 116

78467 Konstanz

Germany

Telephone: +49 (0) 7531 / 876-500
Fax: +49 (0) 7531 / 876-303

Email: support@chromasens.de

Visit our website at http://www.chromasens.de for detailed information on our company and

products.

1.4 About Chromantis

Chromantis is a C++ program from the company Chromasens, which uses the TPAPI to
calculate the multichannel color and spectral information of captured image(s). The diagram
below shows the data workflow from the hardware (image capturing) up to the customer
application or Chromantis.

Customer application Chromasens Chromantis

Chromasens TPAPI

e srEeEns e Customer specific interface

hardware (e.g. hardware like frame grabber)

Figure 1: Work flow of truePIXA application

CD40150 Version R04 5
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The information of an image in TIFF-format, (which can be captured from the truePIXA
hardware, or obtained from customer specific interface, or can be loaded from a hard disk) is
delivered to the Chromasens TPAPI for data processing. The result can be further processed

for customer application, or shown directly in the Chromantis.

Running Chromantis is not difficult. However, the user should have a clear overview about the
available functions to be able to run Chromantis properly. So we recommend strongly reading
over all the function description (in this whole chapter) at first. Now start Chromantis by double
clicking the icon on the desktop, you should see the user interface after a short initialization

process. The user interface looks maybe a little varied because of the various versions, but

the mainly important functions remain the same.

deta E metric [dE1976 ~| de1o9tintent [graphic ans

picker

xxxxx

ssssss

.....

g

Figure 2: The user interface after the first start of Chromantis

The protocol shows which components and files are detected by Chromantis not all files are
loaded at the beginning. Some need to be created during the calibration, but first we need to

learn more about the main functions of Chromantis.

” oo« ” o«

There are pull-down menus for example “File”, “Scan”, “Image”, “View”...on the top left, under
those are some icons which are used as shortcut to run some functions. At the moment, we

only see a protocol window, which shows the running info, in the main window area.

CD40150 Version R04 6
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1.5 Software Requirements

e System
o Windows 7 x64 (recommended), or Windows 8.1 x64
e Optional for using truePIXA-API
o Development Environment
= C++ Compiler (recommended Microsoft Visual Studio 2010 or later)
o System
=  Windows 7 x64 (recommended), or Windows 8.1 x64
e Optional frame grabber software for image acquisition, if it is used to acquire image. (This
software should be provided by the frame grabber manufacture, normally available on the
frame grabber website as download.) About the supported frame grabbers, please refer to

truePIXA-system-requirements in the partner area of the Chromasens homepage.

1.6 Hardware Requirements

e Quad Core >2,20 GHz
e >4GB RAM (recommended >8GB RAM)
e  Graphic card: with more than 1 GB RAM

o Power-supply with enough power for the GPU, camera and all accessories

The raw images from the camera are transformed into multichannel and spectral images on
the CPU. Further calculations from the spectra take place on the CPU. Hence, a powerful
CPU would lead to higher computing speeds. The raw images are temporarily stored in the
memory. Therefore, the RAM memory should be according to the memory requirements
of the respective image sizes. Larger images require larger RAMs. Assume that the source
image with 12 channels has a size of 1GB. If one calculates a destination image with 36
channels from this source image, then the result will be 3 times as big as the source image. All
of this (1GB source + 3GB result) will be located in the RAM. The RAM requirements of other
programs running on the computer, e.g. Windows or any other applications/ processing/
controlling software etc. should be considered while calculating the RAM requirements for
targeted image sizes.

CD40150 Version R04 7
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2 Install Chromantis

First of all, Chromantis must be installed before we use it to scan image, calculate the color

information and evaluate. Double click the executable file setup.exe to begin the setup-assistant.

Wahlen Sie die Sprache aus, die wahrend der
Installation benutzt werden soll:

|English v

Welcome to the Chromantis Setup
Wizard
This will install Chromantis version 1.6.6 on your computer.

Itis recommended that you dose all other applications before
continuing.

Click Next to continue, or Cancel to exit Setup.

Next > ] [ Cancel

Figure 3: Installer-wizard of Chromantis

CD40150 Version R04
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License Agreement
Please read the following important information before continuing. C

Please read the following License Agreement. You must accept the terms of this
agreement before continuing with the installation.

(c) 2014 Chromasens GmbH

All Rights Reserved. No part of this application or any of its accompanying files may
be reproduced, copied, modified, adapted or reverse engineered without prior
written consent from Chromasens GmbH.

Functionality may change and / or be removed, without notice, in future releases.
IN NO EVENT SHALL CHROMASENS BE LIABLE TO ANY PARTY FOR DIRECT,
INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INCLUDING
LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE.

@) I accept the agreement
() I do not accept the agreement

<Back |[ nmext> | [ cancel

Figure 4: Installer-wizard accept the agreement

Here you can choose the path, where Chromantis should be installed. Then choose “I accept
the agreement” to continue the installation.

CD40150 Version R04



_a.|-'E chromasens

Imaging for Professionals

3 Calibrations in Chromantis step by step

This chapter serves as the basis for using Chromantis. However, the user should not only
know the single functionality of Chromantis, but also the whole iteration, how one starts
Chromantis, checks the illumination and camera settings, scans images and does calculation.

So in this Chapter the operation instructions for a whole iteration will be introduced.

3.1 lllumination settings

After all the components were mounted correctly, we can start to do the following steps. First
of all, a constant illumination which is precisely adjusted is the precondition of using
Chromantis. Normally, we use D50 Daylight (UV-cut) as our standard illumination condition.

So the first step is to confirm the illumination settings.

We can use XLC4Commander to manage our illumination device to get D50 (or other
illumination). The detailed information about the illumination adjustment with
XLC4Commander can be found in the manual Corona-Il XLC4. Please note that the device

can give a constant illumination, if the device temperature stays stable.

3.2 Gain value settings

Another very important condition for Chromantis is to set the gain value properly. In this case,
we need to use Camera Setup Tool (CST) to adjust the gain. We put the white reference

material under the illumination and visualize the raw image as line plot.

The goal is to obtain a suitable white reference value, which means, that the four maximal
visualized peaks (for 12 channels) should have almost the same height, and be set to about
190-200 so that they don’t exceed 255 by later processing.

The detailed adjustment process of gain value can be found in the “truePIXA Getting
Started; Chapter 5.2.3 Gain values”.
3.3 Generating black reference (dark offset correction)

In a totally black area, the signal should be 0. But due to the unavoidable little noise, the signal
is not 0 in fact. To suppress such noise, we let Chromantis generate a black reference, so that
the noise can be subtracted lately.

CD40150 Version R04 10
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Setup in Chromantis:

a) Open a Chromantis and click the menu “Scan” > “Configure processing ..

setting dialog.

File | Scan Image Visualize View Info  Window

3 chromasens
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1) To obtain a raw image for “black reference”/’dark offset correction” with Chromantis

.” to open the

“’ Chromantis

File Scan Image Visualize WView Info Window

Scan now
Scanner settings...
Configure process

Manage scanner modules. ..

Figure 5: Configure processing...

b) Set “dynamic WR” to “off”, because this measure should give only the correction value for the

dark current of the sensor.

¢) Uncheck “dark offset correction”.

x
—parameters —post processing
camera dynamic range Isbitfch j crop - left IU crop - top IO
vertical reduction Ia\rerage j crop - right IO crop - bottom IO
dyniamic WR. off - I horizonal fiip
I vertical flip
dynamic WR mode Iimage j
WR cache image I
| ™ dark offset correction |
[™ crosstalk filter
measurement condition IMZ
—output —other
multichannel Ino 'I spectral |no A | setup ID Idefault
sRGB *| L*2** |no - [ auto save to path: I
monitor RGE  |no file name format I
do not spedfy an extension
%4C scan count (4 digits)
%eH hour %M minute %S second
2D day %0 month %Y year
%eT image type
(will be appended automatically if not present)
scan count 1]
reset |

oK Cancel

CD40150 Version R04
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x
—capture
camera is configured to emit IZUDUD,U lines per second
enter CCD resolution (dpi): IIUD,U
transport resolution computed from above data (dpi): 0 update |
[V motor controller present
rEbIE |

Figure 6: Settings for generating black reference

d) Uncheck “soft sync” in the generic scanner settings

e) Cover the camerdfilters with for example a black piece of carton, so that they are completely

covered and scan an raw image
2) To load a raw image for “black reference”/”dark offset correction”
a) File > Open image
3) To compute a “black reference”/’dark offset correction” from a raw image

a) Click menu “Image” > “Compute from image” - “Black reference”, then the black reference
will be generated by Chromantis. It is saved as a file named blackref.8.current in the (hidden)

folder: %ProgramData%\Chromasens\TpApi\

CD40150 Version R04 12
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File Scan | Image Measurement Visualize View Window
] Compute from image Geometry calibration...
Transform Black reference

Filters r White reference. ..
Convert sample type...

1150518-Sino-Raw\crop.TIF =101 x|

Edit
Extras

View mode

Figure 7: Compute black reference

4) - For all further scans the menu item “dark offset correction” should be selected with a
checkmark

- You have to compute a new “dark offset correction” if you change the gain values

3.4 Dynamic WR mode (“Shading correction”/ “flat field correction”)

Dynamic WR is also called “shading correction”. It corrects the effects of natural vignetting and

has 2 different modes: image and cache.

You can apply shading “before geo transform” or “after geo transform”

In tpapi.xml you can define the target gray value of the shading correction in 8bit, <255
(recommended 220-240).

- dynamicshadingtargetlevel = "220"
You can also define the min gray value for applying the shading correction in 8 bit

- dynamicshadingminlevel="10.0"

CD40150 Version R04 13
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In this mode the shading correction will be computed in every scanning process. You need a white

reference stripe in every scanned image. The Position in every scanned image of the area used for

“shading correction” is determined with parameters in the tpapi.xml which are always in millimeters:

- whiterefstart =
- whiterefend =

- showWRarea = “0” or “1”

3.4.2 Cache mode

”

In this mode you need to scan a raw image of a white reference stripe once. It will be used for shading

correction for all further scans.

- Scan a raw image of a white reference stripe which is dark offset corrected. The rows will be

- averaged in the whole image.

- Save the image (for example as white.TIF) and set the path in the tpapi.xml
o WR_mode="cached"

o WR_default_file="C:\ProgramData\Chromasens\TpApi\white. TIF"

transformation settings i il
—parameters — post processing
camera dynamic range ISbitfch j crop - left ID crop - top IO
vertical reduction Iauerage j crop - right ID crop - bottom IO
dynamic WR Iaf'ber geo, transform j ™ horizontal fiip
wvertical fli
dynamic WR mode image =l A g
cache
WR cache image
IV dark offset correction
I crosstalk filter
measurement condition IMZ
—output —other
multichannel Ino 'I spectral |no = setup ID |defau|t
sRGB no | L*=** |no - [” auto save to path: I
monitor RGE  |no = file name format I
do not specify an extension
%%C scan count (4 digits)
2%H hour %M minute %S second
%D day %0 month 36Y year
%I image type
(will be appended automatically if not present)
scan count 0
reset |

(6,4

Cancel

CD40150 Version R04
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3.5 Geometry calibration

To compute the geometry calibration your raw image has to be shading corrected, otherwise

the dots and markers on the geoCHART can’t be detected due to a low signal of some of the
channels.
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Figure 9: geometry calibration chart

a) Scan or open a shading corrected raw image of the geoCHART.

i) The geoCHART should be almost as big as the FOV of the camera, or slightly bigger
i) Atleast 8/10 ArUco marker need to be in the Field of View (FOV) of the camera

iii) Atleast 3 rows of the dots need to be on the image

iv) The transport resolution should be the same as the lateral resolution
v) There should be no saturation in the image

b) Click the menu “Image” > “Compute from image” = “Geometry calibration...” to generate the

geometry calibration file for Chromantis. The information is saved in the file “geometry.xml” in
the (hidden) folder: %ProgramData%\Chromasens\Chromantis\

CD40150 Version R04
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_!| Chromantis

File Sm’!limage Visualize View Info Window
Compute from image Geometry calibration. ..
Bladk reference
White reference...

Color calibration...

Figure 10: Geometry calibration

3.6 Color calibration

In the new version of Chromantis (above v1.58), the user can do color calibration by himself.

a) Scan or open a multichannel image of a colorCHART, which has to be
i. Dark offset corrected

ii. Shading corrected

transformation settings

parameters

camera dynamic range [8bit/ch ']
vertical reduction [subsample ']
dynamic WR [before geo. transform ']
dynamic WR mode [cache ']

WR cache image

dark offset correction
[ crosstalk filter

measurement condition M2

output
multichannel |floating point v | spectral

sRGB L*a*b*

monitor RGB

Figure 11: transformation setting for scanning a multichannel image

CD40150 Version R04
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I
E| image - multichannel
Irmage Plot  Measurerment
1476.3 2131.9 | 232.002 224.666 227.346 238.897 234.292 229.634 240,594 238.140 233.7
E truePIXA-colorCHART CPO00D495-011-02-0297 n
SerialNo:00067 Expiredate:2018-0:4

L]

+

L N B R N

[ A T L B L S S S T B T N B R R R B

L TN B N B D R DA O O DN N DN DN DR D DR T D R

i';ﬁi-chmmasens E

‘||1CD':|

o

Figure 12: Scanned multichannel image of a colorCHART

b) Click menu “Image” - “Compute from image” = “Color calibration...”

CD40150 Version R04
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File Scan | Image Wisualize Wiew Info Window
i im Geometry calibration...
Transform Black reference
Convert sample type... White reference...

Edit Color calibration...
Extras

731
View mode P B

220.0589 219.758

LI I I R I I I I I D IO I IR A L I A R I O L O

Figure 13: Click the menu for color calibration

c) Make sure that your computer is connected to the internet, so the reference data measured by

a spectrometer can be obtained from the Chromasens server automatically.

CD40150 Version R04 18
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Create colorimetric calibration
settings
SpEEIf}-‘thE. r‘negsuremerl':t Ec:,ndltmn b2 [¥] overirite existing dataset on disk
faor this calibration, e.g. "M2 =

reference dataset agquire data
@ autornatict determine matching dataset from image

I manual: specify file to use

automatic mode
@ download from to wansne chromasens.de 1 use local falder

local folder:

| browse..,

manual mode

uze this file:

browse...

additional information
enter rermatks or notes

process

.

Run status: | Success! Close

Figure 14: Settings for a color calibration

d) After pressing Run and the calibration succeeded, the quality of the calibration will be shown
in the protocol window:

L]

37 Using CIEZO0D0

38 Mean delta E = 0.567748 5td dewviation = 0.50326
39 Max deltaE = 3.51624 Min deltaE = 0.051233

40  95% delta E is smaller than 1.53553

41 90% delta E is smaller than 1.08113

42 |=359E delta E 15 smaller than 0.835924

43

e) Restart Chromantis to make the new color calibration available for further scans

CD40150 Version R04 19
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3.7 Color information analysis

After generating or opening a spectral image, the color, spectral or other information can be
analyzed. Sometimes it is useful to get a visualized spectral info, with corresponding L*a*b

values. In this case, you can open or generate a spectral image, and then click “View” - “show

colorimetry window” to check the values. Chapter shows some functionality about the analysis.

Colorimetry x|

"mkaneh'v settings:

delta Emetric [dE 2000 v | dE1954intent |graphicarts 2

picker
IZ“—;I W LMB: xy track I™ xyhul ~mode
= g LMB: collect spectra = follow mouse
 LMB
square ¥ " selection

0,166

3,013

L*a%h*® 36,010 11,842 -£0,703

36,010 11,642 -%0,703

\ | \
\ | \

Adobe RGB =l ‘ 6,067 | 21,792 ‘ 118,044
\ | \

reference L™ ‘ [ ‘

dettaE 0,000 dearref. | setref.

protocal file | rawD |

spectral chromaticity

»
e

deor callection | || export collection,. | | dear tradk G

Figure 15: Colorimetry window

CD40150 Version R04
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Table: Settings for various situations by using Chromantis

Imaging for Professionals

Scan raw Scan raw Scan multichannel Scan spectral image
image for image for image for color After all calibrations were
black geometry calibration done
reference calibration

Camera 8bit/ch 8bit/ch 8bit/ch 8bit/ch

dynamic range

Vertical Average or Average or | Average or Average or subsample

reduction subsample subsample | sybsample

Dynamic WR off Before geo | Before geo transform | Before geo transform

transform

Dark offset unchecked checked checked checked

correction

Measurement M2

condition

If M2.dat is

given, then

please make

sure M2.dat

exist in the

folder...

%ProgramData

%\Chromasens\

TpApi\

Output- No No Floating point no

multichannel

Output-spectral No No No Floating point

The table shows, how to set proper values for various scan situation. Depending on which

type of image should be generated directly after scanning.

CD40150 Version R04
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4  Further functions in Chromantis

41 File
With the menu “File”, the user can do the following operations.

411 Openimage

If you want to load an image, which is already saved on the hard disk, you can click this menu

item to open it. TIF is the only supported format. Several images can be opened and shown in

separate tabs.

B e i File  Scan Image Visualize View Help
Open image... Ctrl+0 . ‘ :' ¢
Save image... Ctrl+5 5 u e
1 Language loaded OK
Cuit on found 2  No TpApi installation found
ound process: Scanner 3  Exception in background process: Scanner
4 CApplication::OnInit: 4  CApplication::0OnInit:
g Init complete. 5 Init complete.
6

or

Figure 16: Import TIF-image in Chromantis

+ v oo T T -

File Image Plot Measurement Tests

4o.5 1579.2 | 0.000  0.000 . 0.000-  0.000  0.000  0.000  0-081  0.232 _ 0.267 -0.014 _ 0.105 _0.15]
Tl i 00009 i 2016-06 L)

L A S S TR T S S Y S S S A S T TS

LA A T R T I I T B NN Y Y SN S S SENE SN S JNE S S Y S W S 3

L 1 T il

000 0lo0 00 7

Figure 17: Show TIF-image in Chromantis

You can switch between the channels by using “space”. In the upper part of the window the

channel values of the current cursor position are shown.

CD40150 Version R04 22
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4.1.2 Save image
The image in the current window in Chromantis can be saved with File > Save image...

the format of saved image is also TIF.

-
B " truePIXA colorCHART.TIF

| Image Plot Measurement Tests

Open image... b0 bo 533,477 231.284

Save image... Ctrl+5 SerialNo:0000

Close window

Figure 18: Menu point “Save image...”

4.1.3 Quit

If you want to close the image window or the application, you can choose the menu point “File”

or you can also click the control element X upright to finish the program.

4.2 Help

421 Chromantis manual
In the new version by clicking “Help” = “Chromantis Manual”’, a manual in pdf-format will be
opened.

4.2.2 About Chromantis

The current version number of Chromantis will be shown by clicking “Help” > “About
Chromantis”.

9 romants T —

File Scan lmage Visualize View [Help |

b 4 Chromantis manual
I W

Language loaded OK v About Chromantis
2 No TpApi installation Touna
2 FTOADT] TAasdsna masciimaman + randadann Fonam Co\DinAanna

Figure 19: About Chromantis

CD40150 Version R04 23
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4.3 Image

4.3.1 Transform

With this mode you can transform an image format into another. You can only transform the

following combinations:

Raw image - raw image (if you want to subtract the dark offset or apply a shading

correction)
Raw image - multichannel image (you need a geometry calibration file to do this)

Multichannel image >spectral image; sRGB; Lab 8bit (you need a color calibration file to
do this)

Spectral image >16bit Lab image

4.3.2 Transform raw image - multichannel image or raw image >raw image

a) First you need to adjust the settings of the target image.

transformation settings

—parameters
camera dynamic range ISbit,."d‘l j
vertical reduction Iaverage j
dynamic WE. fi . transform
dynamic WR mode Iimage j
WR. cache image I

¥ dark offset correction

[T cosstalk filter

measurement condition IMZ

—output
multichannel Iﬂnaﬁng point vI |spectra| no -
sRGE no b L¥a*h* no -
monitor RGE  |no %

Figure 20: Settings which are used for Transform (Raw = Multichannel)

b) Then you transform the image by clicking “image” >”transform from” =>”the actual source

image form”

CD40150 Version R04 24
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Plat  Mleasurement

Sl g e Ctrl+S (s 063 3.642z l6l.z04 30,
Cormpute from image k]

Transform from » Raw irmage

Coreert sample bype.., . Multichannel image ...

Ed|t Spectral irmage

Fast 12-to-3 downrmi..,

Figure 21: Choose the source image form you want transform from, it is not the target image

4.3.3 Transform multichannel image > spectral image (or sRGB, 8 bit L*a*b* image)

After clicking menu "Image” - “Transform from” - “multichannel image...” you can decide the

output type and then get the corresponding result.

transform multichannel X|

—parameters

measurement condition IME

—autput
spectral  |jLElyaslyial 7| SRGE |no hd
L*a*b* |no -

oK | Cancel |

4.3.4 Fast12 to 3 downmix

This function requires a 12 (multi) channel image as input. It generates an RGB-image as

result, which R, G, B can be adjusted, weighted and summed from the entire 12 channel.

CD40150 Version R04 25
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Convert sample type...
Edit »

View mode 4

Multichannel image ...

Spectral image ...
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Figure 22: Create overview RGB from multichannel
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4.3.5 Convert sample type

Normally, the scanned image as source has the data type of 32 bit float. If the image is
loaded, the content is allocated in the memory, pixel-wise from left to right, from top to bottom.
Every pixel holds a certain number of channels and the value in every channel is a 32 bit float
type. Sometimes if we need to transform the value from 32 bit float into 8 bit unsigned (or
signed) integer, we can click “Image” > “Convert sample type...”. After such a transformation,
the image has a smaller size and can be viewed by some other image viewer tools directly.

The transformation into 16bit or 32 bit is at the moment not available.

convert mage depth T

—destination depth

IB bitfchannel, unsigned j

—copy mode
= replace original

* create copy

Ok Cancel

Figure 23: Convert image depth

4.3.6 Edit

e Crop to selection

The user can select a region on the source image by (left)pressing und dragging the
mouse, then click “Image” - “Edit” = “Crop to selection”, the image will be cropped to

the selected region.

“" Chromantis
File Scan | Image Visualize View Info Window

=t Compute from image r
— W= Transform ]
Convert sample type...

Extras » Copy selection as text
BN D:\xz [T 91324 \Chart0011_01.TIF
|

Figure 24: Crop to selection
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e Copy selection as text

The user can select a region on the source image by pressing und dragging the
mouse, then click “Image” 2> “Edit” > “Copy selection as text’, the values of the first

channel of the region will be copied as a text block and can be pasted in any text
processing tools.

[} chromantis

File Smnllmage Visuzlize View Info Window

a Compute from image 4
i | Transform r

Convert sample type...

Crop to selector

Extras g Copy selection as text
£ D:\)Z [T —— W )324\Chart0011_0L.TIF
]

Figure 25: Crop to selection
44 Plot

441 Selection intensity profile

With this option you can get a horizontal or vertical line profile of the camera signal in your image

a) Select a region on the image with your cursor

b) Plot>Selection intensity profile>horizontal or vertical

Image Measurement

Selection intensity profile horizontal

vertical

4.5 View

451 Show protocol window

A protocol window is open by default setting. It records usually the application info by running.
If there would be some unexpected errors by executing some functions, they should be also
be logged, so that the user can be informed with the help of protocol window.
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- Elllw 3

Language loaded OK
No TpApi installation found
[TPAPI] loading measurement condition from C:\ProgramData‘chromasens'tpapi\M1.DAT

10 [TPAPI] TpApi init complete
11 Exception in background process: Scanner module directory does not exist..
12 capplication::OnInit:

13  Init complete.

Figure 26: Protocol window

4.5.2 Show colorimetry window

[TPAPI] loading measurement condition from C:\ProgramData\chromasens\tpapi\M2.DAT
[TPAPI] Toaded default black reference from C:%\ProgramData‘chromasens'tpapi‘iblackref.8.current

[TPAPI] Can't read white point file file; WP adaption not available.

The colorimetry window works on an opened spectral image.

N
Colorimetry

x|
r—colorimetry settings
delta E metric IdE 2000 | dE 1994intent Igraphic arts e
¥ LMB: xy track ™ xyhul ~mode
JF=|
! 7 LMB: collect spectra & follow mouse
 LMB
" selection
0,187 ‘ 0,166 | 5,013
10,113 ‘ 5,013 | 35,047
6,067 ‘ 21,792 | 118,044
36,010 ‘ 11, 647 | —60, 703
36, 010 ‘ 11, 642 | —&0, 703
0,000 dearref. | setref.
row ID |
chromaticity
clear collection | export collection,.. | dear track dear hull

e
size 20 =
shape frauare 2]
~results
Xyt |
Xz |
[adoberes =] |
L*a%® |
reference L%ab* |
delta E
protocol file [
spectral

Figure 27: Colorimetry window

The mouse area on the spectral image is a square. The size of the square can be adjusted.

The values in the area will be averaged. So if there is some noise on the spectral image and

the noise should be suppressed, then a bigger size can be useful. If the user wants to do color

inspection in a small area, so the square should also be small.
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As the mouse moves, the values of various color spaces change too. If the user (left) click the
mouse, the L*a*b* value of the current area is considered as reference. For a color
homogeneous surface, the value of L*a*b* of the area around the reference point doesn’t

change much, and delta E should be therefore small.

Delta E metric has three various criteria dE1976, dE1994, dE2000. In dE1976 is delta E the
Euclidean distance in L*a*b* color space. dE1994 and dE2000 uses additional parameters to

describe and adjust the different visual sensitivity of certain colors.

If protocol file (e.g. it can be a txt-file.) and row ID are given, after clicking with the mouse of
the spectral image, the spectral data will be written in the protocol file, and the row ID will be

increased every time after clicking.

(Some functions of this colorimetry window are not yet available: LMB:xy track; LMB:collect

spectra; xy hull; mode; clear ref.; set ref.; clear track; clear hull)

4.6 Key sequences

If the functions are not yet integrated in menu, the user can still use them via key-combination
e Single channel

For multichannel image, the value of every channel can be read. With keyboard
shortcut “Ctrl+Shift+G”, then use the space-button to see the current channel value at
the top of the image. By clicking the space-button further, the little arrow above will
move to the next channel. All the pixel value from the current channel will be displayed

as a greyscale image.

[ Chromantis - [D:\XZ\Daten\MultiSpekiral\20150324\Chart0011_01.T1F]

5| File Scan Image Visualze View Info Window
r— o
[EI] ‘ d- L
.51 70.605 89.833 94,405 25.898

ChartMNo.0011-Rev.01
B Sice-11.6x11.6mm-Paiches-30x22

Figure 28: View mode single channel

e RGB groups

The user can press space-key, to switch different RGB views. That means the 3

channels will be grouped.
e Channel average

The values of a pixel of all the channels will be averaged and shown in one image.

With the keyboard shortcut “Ctrl+Shift+A”, the user can see the averaged result.
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